We thank you for your purchase of the mediaBOX Media Player. The mediaBOX is a reliable small form factor device, which was designed to deliver uninterrupted playback of Digital Signage and Kiosk presentations. We are confident the device will perform to specification for years to come and thank you for your interest in this Media Player.

We have taken extreme measures to make sure the mediaBOX is 100% reliable and conforms to our certification process. Each mediaBOX Media Player is passed through rigorous system quality assurance of hardware and software prior to delivery. Be sure to notify your reseller if you find damaged components which may have resulted from shipment or if you find that something is missing from the original packaging.

DISCLAIMER: WHILE MAKING EVERY ATTEMPT TO PRESENT INFORMATION ACCURATELY IN THIS MANUAL / PUBLICATION, THE COMPANY DISCLAIMS LIABILITY FOR ANY LOSS OR DAMAGE ARISING FROM ITS USE. THIS MANUAL / PUBLICATION SHOULD NOT BE RELIED UPON AS A SUBSTITUTE FOR LEGAL, TECHNICAL OR OTHER PROFESSIONAL ADVICE.

The manual should only be used with the supplied version of the software and hardware. Any other use may result in loss or damage to the operating system or to the device itself.

This manual is for Windows embedded standard edition (XPe) or Ubuntu 9.04 32 /64 bit. The manual is to be used as a basic guideline for the mediaBOX Digital Signage and Kiosk Media Player.
## TABLE OF CONTENTS

### 1.0 GENERAL INFORMATION
- 1.1 Package content
- 1.2 Pre installation requirements
  - 1.2.1 Ethernet
  - 1.2.2 Wireless
  - 1.2.3 Video
  - 1.2.4 Sound
- 1.3 Things to consider
- 1.4 Overview
  - 1.4.1 Network
  - 1.4.2 Monitor and video display
  - 1.4.3 Capture device
  - 1.4.4 USB OS restore system
- 1.5 Specifications
- 1.6 Formats
- 1.7 Panel configuration

### 2.0 The Digital Signage Network
- 2.1 Connecting to the Digital Signage cloud
- 2.2 Registering into the Digital Signage network
- 2.3 Broadband
- 2.4 Security
- 2.5 Firewall

### 3.0 Windows Embedded Standard setup and configuration
- 3.1 Windows user interface
- 3.2 Network setup
  - 3.2.1 Wired network
  - 3.2.2 Wireless network
  - 3.2.3 Host name
- 3.3 Display configuration
  - 3.3.1 Single Display
  - 3.3.2 Dual Displays
  - 3.3.3 Rotating the Display
- 3.4 Running the SignagePlayer
- 3.5 Unregistering & clearing cache
- 3.6 Maintenance
- 3.7 Remote Login
- 3.8 White label setup
4.0 Ubuntu Linux

4.1 User interface
4.2 Network setup
  4.2.1 Wired network
  4.2.2 Wireless network
4.3 Display configuration
  4.3.1 Single Display
  4.3.2 Dual Displays
  4.3.3 Rotating the Display
4.4 Running the SignagePlayer
4.5 Enable HDMI sound
4.6 Maintenance
4.7 Remote Login
4.8 White label setup

5.0 Monitoring and Administration

5.1 Watchdog
5.2 Real time snapshots
1.0 GENERAL INFORMATION
1.1 Package content

The mediaBOX Media Player is shipped pre assembled and ready to play. It is a plug N play device which was designed to deliver seamless integration even for none technical individuals. The following is a list of the products you received with the purchase of your new mediaBOX Media Player. Please note that most of these components were pre-installed at the factory.

- System Motherboard with built in Video, LAN, NIC and sound interfaces.
- Wifi internal USB module with external antenna
- Intel based processor **
- Standard CPU fan
- Slim hard drive with SATA cables
- DIMM2 240 pin Memory **
- Motherboard manual with drivers CD
- Internal 150PSU DC-DC convertor
- 120V-240V AC-DC convertor
- Mini mediaBOX hard metal case with detachable front plate
- Motherboard manual and drivers CD
- Mounting plates, side brackets, rail mounts, HDD plate, extra fan ***
- USB OS Restore system ***
  - The OS restore system includes x2 USB Flash drives
- Internal USB Capture device with external connectors ***
  - Capture device board with RCA/S-Video pigtail, CD Drivers & plug-in wires

** Component specifications depends on the mediaBOX model ordered

*** Item sold separately as an add on accessory
1.2 Pre installation requirements

The following are things to consider before you install the mediaBOX Media Player.

1.2.1 Ethernet

The mediaBOX is equipped with Ethernet 10/100/1000MB onboard internal network interface card. If you wish to use a wired local area network connection be sure to run Cat 5 twisted per Ethernet cable to the final mounting location of the Media Player. The cable must be plugged into a LAN switch or router with a maximum distance of 100 meters. Distance may be extended with a repeater.

1.2.2 Wireless

The mediaBOX has a built in 802.1x compatible wireless network card. The internal card is connected to one of the six available USB header port that is available on the motherboard. The wireless interface card must be connected to the supplied antenna in order to insure maximum reception of available wifi signal. In order to take advantage of the Wifi capabilities of the mediaBOX Media Player, be sure to install a Wireless router within close proximity. Actual signal strength and maximums wireless distance may vary due to local interference and building layout. You should perform signal quality tests to confirm the device can properly work with your current wireless configuration.

1.2.3 Video

The mediaBOX Media Player supports all high definition formats including 720P and 1080i. The Media Player is equipped with VGA / HDMI and DVI video ports. Be sure to prepare the proper cabling to connect the Media Player directly to your LCD or Plasma screen. You may need a convertor (i.e.: HDMI to DVI) to establish proper connections between the Media Player and legacy devices.

1.2.4 Sound

The mediaBOX Media Player supports high definition sound. You have the option of using the optical, coax or mini jack sound ports. If you wish to have support for audio be sure to consider the physical installation of the speakers. Refer to the back panel diagram for a complete layout of all audio ports.

1.3 Things to consider

The mediaBOX Media Player is an advanced device which needs to be handled with care. It's important to install the device in areas where room temperature does not exceed 90 degrease Fahrenheit (32.22 Celsius). External heat may cause the device to overheat internally. Be sure to protect the device from theft by hiding it behind a monitor or other enclosed furniture. The mediaBOX is designed to auto restart after a power outage. Uninterrupted power supply is not necessary for safe operation of the Media Player.
1.4 Overview

1.4.1 Network

The mediaBOX depends on reliable internet connectivity to get data updates, stream down media files into its caching repository and report back to the server and SignageStudio on its own health status. Once files are cached the Media Player will only communicate back with the hosted Digital Signage servers if an update is initiated from the SignageStudio, or if the Media Player is rebooted.

A constant internet connection (a connection that is always up and active) is not required as the mediaBOX Media Player will cache content internally (using the internal hard drive). The mediaBOX also supports manually updating content via portable devices such as a USB flash drive. Manual content update can be used in areas where internet connection is not available.

You may choose to connect to the local area network via wireless or wired interface. The wireless method reduces cabling requirements and is normally the preferred way of connection when installing the Media Player behind a monitor.

The mediaBOX is shipped with DHCP enabled and will automatically retrieve an IP from a local area network DHCP Server or NAT enabled router. You may reconfigure TCP/IP settings. Refer to the Ubuntu / Windows XPe respectively for further information on configuring network connections. The mediaBOX does not require a static IP; auto assigned private IPs are fully supported.

The mediaBOX internal firewall is disabled by default. All egress and ingress communication is done over the TCP/IP protocol and live socket connection exists between it and the backend digital signage server cloud.

1.4.2 Monitor and display setup

The mediaBOX supports up to two monitors consecutively. It includes VGA / DVI / HDMI connections through the back panel. You may choose a combination of any two types of connectors to achieve a dual display setup. Two monitors of same or different resolution may be connected to produce a total desktop width or height, which is the total resolution combined.

If the monitors are configured in a landscape mode the total desktop width is monitor A width + monitor B width. If the monitors are configured in portrait mode the total desktop height is monitor A height + monitor B height.
1.4.3 Capture device

The mediaBOX may be purchased with a built in Capture device (also known as a TV Tuner card). A capture card will allow you to connect external peripherals and display the output of these devices directly onto a specified screen division. The capture card connections include S-Video and RCA Audio / Video inputs.

The capture device can be connected to any input source including external DVD players, satellite box, cable box, security camera systems and others. The capture device can be configured using the SignageStudio using one of two methods:

Method #1: Use the Capture / Web Component in the SignageStudio to assign a capture device into a screen division. Using this method you may experience some latency, average quality with interlacing. This method is also processor intensive as all captured frames must pass through the Flash / AIR Adobe virtual machine. On the up side, it is easy to setup and requires no special configuration.

Method #2: Use the External Application Component in the SignageStudio. The External application can take any external binary executable and so no CPU overhead is involved in the capturing process (frames processed by the Video card’s GPU) and no latency will be present. The recommended applications to be used to achieve this setup are TVTime (Ubuntu), Virtual Dub (Windows) or VLC (Windows and Ubuntu); all are open source, freely distributed and are pre installed and configured on the mediaBOX Media Player.

1.4.4 USB OS restore system

The USB operating system restore device may be purchased as an add-on accessory for the mediaBOX Media Player. The USB OS restore system allows for a complete restore of the entire OS (Windows XPe or Ubuntu) in about 60 seconds. This is ideal for environments where customers are interacting with the device (Kiosks / Internet Cafés) and may corrupt the underline OS.

In such environments the USB OS restore system allows for a quick and easy way to get the mediaBOX Media Player up and running in no time.

Another key advantage of the USB OS restore system is the ability to easily upgrade the entire OS into the latest software revision. Simply download the last released mediaBOX OS build
from your reseller’s web site and onto the supplied USB flash device. Once the download is complete you may follow the steps below to apply the new OS image to the Media Player.

The USB OS restore system includes (2) USB flash memory devices. The 1st USB device marked as “Program” contains the restore utility which is used to boot into the restore application. The 2nd USB marked as “Image” holds the operating system (Windows XPe or Ubuntu) that is used to restore back the complete OS to its default state.

The following section describes in the detail the process required to restore a Windows XPe or Ubuntu Linux OS back to the factory defaults.

Operating systems restore point procedures:

**Attention:** please note that imaging your mediaBOX Media Player will erase all its content including cached media files. It will completely wipe out your existing hard disk. You should make backups of any files or data which you would like to save. Note that you do not need to backup any files for proper operation of the mediaBOX. Once you reimage the Media Player you will be prompted to re-register with your login email and password. Once you complete registration and select the campaign to join, the SignagePlayer will download your digital signage or kiosk configuration and begin to re-cache all resource files.

Begin by inserting the two supplied USB flash memory cards into any available USB ports. Next, turn on the mediaBOX Media Player. As soon as the first bootup screen appears, press the [Delete] key to enter the BIOS config mode.
On the main BIOS screen select “Advanced BIOS features”.

On the “Advanced BIOS features” change the 1st Boot Device to USB-ZIP, change the 2nd Boot Device to USB-FDD and change the 3rd Boot Device to ZIP-100.

Next use the arrow keys to move around the menus and select the “Hard Disk Boot Priority”. Press [ENTER] to view the properties. Use the Page Up and Page Down keys and set the 1st item to “Bootable Add-in Cards”.

---

**Phoenix - AwardBIOS CMOS Setup Utility**

<table>
<thead>
<tr>
<th>Standard CMOS Features</th>
<th>Frequency/Voltage Control</th>
</tr>
</thead>
<tbody>
<tr>
<td>Advanced BIOS Features</td>
<td>Load Fail-Safe Defaults</td>
</tr>
<tr>
<td>Advanced Chipset Features</td>
<td>Load Optimized Defaults</td>
</tr>
<tr>
<td>Integrated Peripherals</td>
<td>Set Supervisor Password</td>
</tr>
<tr>
<td>Power Management Setup</td>
<td>Set User Password</td>
</tr>
<tr>
<td>PC Health Status</td>
<td>Save &amp; Exit Setup</td>
</tr>
<tr>
<td></td>
<td>Exit Without Saving</td>
</tr>
</tbody>
</table>

**User’s Manual**
Next press F10 to save changes and [ESC] to exit and reboot the device. Once the Media Player is rebooted it should enter the OS restore utility program.

**NOTE:** If you get an error of “Remove Disks or other Media, Press any key to restart”, you will need to swap the two USB locations. Once they are swapped, reboot the mediaBOX one more time.

On the main restore utility screen press [ENTER] to continue (this is the orange menu screen).

1. Select default “en_us UTF-8” English
2. Select default “Don’t touch keymap”
3. Select default “Select Mode: Start”
4. Select default “device-image work with disk or partitions using images

5. Select default “local_dev Use local device (e.g.: hard drive, USB drive)

6. Select default “Press Enter to continue…”
7. Select Flash USB Drive (4GB – 8GB Drive)
8. Select default “top_directory_in_local_device”
9. Select default “Press Enter continue”
10. Select default “Beginner mode: Accept default options”
11. Select “restoredisk Restore an image to local disk"
12. Select the image you would like to restore
13. Select default “80GB” hard drive
14. Select default “Press Enter continue
15. Enter “y” and Enter to continue when asked to confirm
16. Enter “y” and Enter to continue when asked to confirm again
17. When restore is done, remove the USB drives and reboot the Media Player

To update and re-image the entire operating system with a new version image, you must first download the new image from your reseller’s web site. The OS image is in a zipped file format. Unzip the file onto the 2nd USB device labeled as “Image”.

Make sure that the unzipped directory resides on the root of the USB. For example, if the unzipped image you downloaded contains a base folder name “LinuxVersion14”. The “LinuxVersion14” must reside directly on the root of the USB “Image” device and not within any other sub directories.

Once the newly downloaded folder is unzipped onto the USB flash device, you may follow the steps above to completely reimage the entire operating system with the new version.

1.5 Specifications

<table>
<thead>
<tr>
<th>Feature</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>GeForce 9300 GPU</td>
<td>• GPU clock: 450 MHz (Overclockable)</td>
</tr>
<tr>
<td></td>
<td>• Shader clock: 1200 MHz (Overclockable)</td>
</tr>
<tr>
<td></td>
<td>• 16 stream processors</td>
</tr>
<tr>
<td></td>
<td>• Microsoft DirectX 10 with Shader Model 4.0</td>
</tr>
<tr>
<td></td>
<td>• Low profile super quite, single fan system</td>
</tr>
<tr>
<td></td>
<td>• External DC-DC Power supply</td>
</tr>
<tr>
<td></td>
<td>• Ultra small form factor design</td>
</tr>
<tr>
<td>Intel Core 2 Duo™</td>
<td>• 1 HD Audio Port (Line-in, Line-out, MIC-in)</td>
</tr>
<tr>
<td>Intel Core 2 Quad™</td>
<td>• 1 SPDIF Coaxial connector</td>
</tr>
<tr>
<td>Intel Core 2 Extreme™</td>
<td>• 1 SPDIF Optical connector</td>
</tr>
<tr>
<td>Intel Pentium™ family</td>
<td>• 1 PS/2 Keyboard Port</td>
</tr>
<tr>
<td>Up to 1333 MHz FSB support</td>
<td>• 1 COM port header</td>
</tr>
<tr>
<td>LGA775 Socket compatible Up to 1333 MHz FSB</td>
<td>• 12 USB 2.0 (6 on back panel, 6 via pin header)</td>
</tr>
<tr>
<td></td>
<td>• 1 RJ45 Port (Gigabit Lan)</td>
</tr>
<tr>
<td></td>
<td>• 1 VGA</td>
</tr>
<tr>
<td></td>
<td>• 1 DVI (w/Audio)</td>
</tr>
<tr>
<td></td>
<td>• 1 HDMI (w/Audio)</td>
</tr>
<tr>
<td></td>
<td>• 1 NVIDIA nView multi-display (up to 2 monitors)</td>
</tr>
<tr>
<td>Dual Channel DDR2</td>
<td>• DDR2 667/800</td>
</tr>
<tr>
<td></td>
<td>• 2 x 240 pin DDR2 DIMM slots</td>
</tr>
<tr>
<td></td>
<td>• Up to 8GB ram</td>
</tr>
<tr>
<td></td>
<td>• 1 PCI Express 2.0 x16 (needs different case)</td>
</tr>
</tbody>
</table>
2.0 System Summary

<table>
<thead>
<tr>
<th>OS options:</th>
<th>NVIDIA PureVideo HD support•</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Operating system</td>
<td>NVIDIA Hybrid SLI with GeForceBoost•</td>
</tr>
<tr>
<td>Microsoft™ windows standard edition</td>
<td>NVIDIA Unified Architecture•</td>
</tr>
<tr>
<td>embedded peripheral</td>
<td>NVIDIA CUDA Ready•</td>
</tr>
<tr>
<td>Linux Ubuntu 9.04 peripheral optimized</td>
<td>NVIDIA PhysX Ready•</td>
</tr>
<tr>
<td></td>
<td>Native HDMI with HDCP•</td>
</tr>
<tr>
<td></td>
<td>Integrated 802.11b/g WiFi</td>
</tr>
</tbody>
</table>

| 2 SATA 3.0 Gbps ports•      | 2 SATA cable•               |
| 1 e.SATA 3.0 Gbps port•     | 1 SATA power cable          |

| Plug N play installation    | All components are none proprietary and upgradable |
| Designed for the SignagePlayer |                                           |
| 30 days direct warranty     |                                               |
| 1 Year warranty with manufacturer |                                          |

| Windows XPe details:        | Ubuntu Linux details:                  |
| Requires licensing per single OS | Requires no licensing, freely distributed OS |
| Ultra light Windows manager used | Ultra light Windows manager (source Black Box) |
| No Desktop icons and no shortcuts | No Desktop icons and no shortcuts |
| Pre loaded with SignagePlayer Pro | Pre loaded with SignagePlayer Pro |
| Disabled Adobe AIR auto build updates | Disabled Adobe AIR auto build updates |
| Disabled all screen saver | Disabled all screen saver |
| Disabled all balloon & other OS messages | Disabled all balloon & other OS messages |
| Disabled scan disk and other file checks | Disabled fstab and other file checks |
| Removed Taskbar | Removed Taskbar |
| Set as appliance mode device | Set as appliance type application |
| Pre loaded with all supported drivers | Pre loaded with all supported drivers |
| Removed services and TSRs not needed | Removed daemons and TSRs not needed |

1.6 Formats

The Player supports all of the native Flash 10.X+ formats which include the following:

Video Formats: Flash video FLV (H.263), MPEG-4 (H.264), MOV, M4A, MP4V, 3GP, 3G2, AAC (HE, LC), SWF

Animation: SWF

Images: JPG, PNG

Sound: MP3

You may also use the External Application component of the SignageStudio to integrate binary external applications into an assigned screen division. This allows you to use applications such as the open source freely distributed media player software called Video LAN (aka VLC).

To learn more about VLC and its supported formats you may visit the following link:

http://www.videolan.org/vlc/features.html
1.7 Panel configuration

The image below maps the main ports of the BACKBOX back panel.
2.0 THE DIGITAL SIGNAGE NETWORK
2.1 Connecting to the Digital Signage Cloud

The Digital Signage network cloud is comprised of network servers and routers which are hosted at central data centers. The hosted servers provide all services to your Digital Signage network. This type of service is often referred to as SaaS (software as a service). The services include authentication, streaming of media files and database services. In order for the mediaBOX Media Player to join this cloud, you must first register the Media Player. Next you will need to insure that the Media Player can transmit ingress and egress data from and to the digital signage cloud. The following sections will cover requirements for proper operation and transmission of your mediaBOX within the SaaS model.

2.2 Registering into the Digital Signage networks

The mediaBOX ships preloaded with a stable version of the SignagePlayer. When a Media Player boots up, the SignagePlayer is configured to automatically start. On the 1st boot up you will be prompted to enter your login email and password. These will be the same email and password you use to login to the SignageStudio. Once you provide this information, the Media Player will be associated with your account. After proper authentication is completed, the Media Player will be allowed to join your digital signage network.

Once successfully registered, the SignagePlayer will prompt you to select the campaign and output that you would like to connect to. The campaign and output can be modified at a later time through the SignageStudio “Stations”.

2.3 Broadband

The mediaBOX Media Player relies on a broadband connection to download all of the campaign’s data. This includes RSA authentication, XML configuration and media files. It also uses the broadband to access external data sources such as RSS, video podcasts and other data. It is vital to a successful integration of a digital signage solution that you provide a fast reliable internet connection. It should be noted that the SignagePlayer will work with almost any type of connection; the SignagePlayer uses internal caching and retry mechanisms to insure smooth playback at all times.

The SignagePlayer will not be affected when internet connection is down given that all resources had an opportunity to cache locally. The SignagePlayer may also be rebooted when no connection exists; in such scenarios the SignagePlayer will roll back to the last good known campaign. However, a fast broadband connection will allow for rapid download of content, smoother transitions into new content and more reliable remote control functionality.
2.4 Security

The SignagePlayer uses an elaborate authentication scheme to validate against the Digital Signage servers. Once fully authenticated, the SignagePlayer will be allowed to join the Digital Signage cloud. The SignagePlayer uses 128 bit private and public keys. It is powered by RSA ciphering cryptography to insure maximum security. All tokens used are validated on the server side before they are allowed to pass through.

The SignagePlayer stores the authenticated password locally within the local file system as an encrypted key. If you plan on moving the Media Player or possibly shipping it to an offsite location, consider first unregistering the SignagePlayer. Unregistering the SignagePlayer will remove it from the Digital Signage cloud as well as remove all locally saved passwords.

2.5 Firewall

The SignagePlayer communicates with the hosted servers over TCP/IP. The protocol uses http (as well as RSA public / private keys over standard http) and raw sockets. In order to insure proper operation the SignagePlayer must be allowed to communicate with the hosted servers within the Digital Signage network.

The mediaBOX does not include an internal firewall and so no special configuration is required. However if your local area or corporate network does have a firewall, you will need to insure proper rules exist within your firewall to allow traffic originating from the mediaBOX to pass through.

If you are having issues connecting to our server you must have issues with a local firewall. We support both LIVE Sockets as well as HTTP Polling.

Under the SignageStudio > Stations you may get 3 color indicators:

Yellow: connected via Polling
Green: connected via live socket
Red: not connected at all

To learn more about this and how it is setup, please watch this video tutorial:

Note that if you have a firewall with an existing port 80 rule, this may NOT be enough. The reason is that many firewalls will only allow HTTP traffic. However, the mediaBOX communicates using a persistent TCP/IP socket connection. You may need to add a rule in your gateway / router to specifically allow connection oriented traffic over port 80 (not just HTTP).

You should know that opening port 80 on your firewall does not compromise in any way the security of your local area network. Allowing trusted traffic originating from within the LAN onto a specific destination is common practice. It does not induce any potential security breach. This is acceptable and standard procedure in internet security models.
3.0 Windows Embedded Standard setup and configuration
3.1 Windows user interface

The mediaBOX Media Player was designed as a plug-N-play device. The Media Player requires very little maintenance after the initial setup. The Windows XPe was compiled with a light weight windows manager. In order to fully optimize memory and resources the windows was stripped down from both Desktop and Taskbar controls.

The main user interface is the Task Manager. The Task Manager allows you to accomplish basic tasks including execution of installed applications, restart, shutdown and basic process management.

To access the Task Manger press **Control > Alt > Delete sequentially**.
This will open the Task Manager and expose the File > Run command interface.
The run command interface is used to execute applications.

3.2 Network setup

3.2.1 Wired Network

The mediaBOX ships with DHCP enabled by default. To access the wired network configuration:

1. press **Control > Alt > Delete** to open the Task Manager
2. On the Task Manager select **File > run**
3. Type **control** and select ok. This will open the main control panel.
4. Select **network connections**
5. Double click the main network interface
6. Configure static IP information or DHCP settings

![Local Area Connection Properties](image)

### 3.2.2 Wireless Network

The mediaBOX ships with DHCP enabled by default. To access the wireless network configuration:

1. Press **Control > Alt > Delete** to open the Task Manager
2. On the Task Manager select **File > run**
3. Type `control` and select ok. This will open the main control panel.
4. Select **network connections**
5. Double click the wireless network connections
6. Click refresh network list and search for your local area wireless network. Double click to connect to a selected network

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>LAN or High-Speed Internet</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Local Area Connection</td>
<td>LAN or High-Speed Inter...</td>
<td>Connected</td>
</tr>
<tr>
<td>Wireless Network Connection</td>
<td>LAN or High-Speed Inter...</td>
<td>Connected</td>
</tr>
</tbody>
</table>
3.2.3 Host name

The mediaBOX comes preconfigured with a default host name called OEM. When running multiple mediaBOXes in the same virtual network, you may encounter an error on the screen since multiple mediaBOXes have the same host name. The Windows OS requires that each host has a unique identifier. To apply a unique name to each one of your mediaBOXes follow these steps:

1. Press Control > Alt > Delete
2. Select File > run and type regedit, and then click OK.
3. Locate the following registry key:
   
   HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
4. To change the company name, do the following:
   
   In the right pane, double-click RegisteredOrganization. Under Value data, type the name that you want, and then click OK.
   
   To change the name of the registered owner, do the following:
   
   In the right pane, double-click RegisteredOwner. Under Value data, type the name that you want, and then click OK.

   Click Exit on the File menu to quit Registry Editor.
3.3 Display configuration

The mediaBOX Media Player comes with 3 types of display connections including VGA, DVI and HDMI. You may use any one of these ports for your main display.

The mediaBOX Media Player also supports up to two active monitors per single box. When using two monitors you will have a desktop space which is a total of both monitor resolutions combined. In other words, you may create a signage presentation that spans both monitors. You can also configure the monitors in landscape or portrait mode.

3.3.1 Single Display

To configure the resolution of your display:

5. Press **Control > Alt > Delete**
6. Select **File > run** and type control
7. Under the control panel double click on **Display**
8. Select the **settings** tab
9. Select the resolution you wish to set using the resolution slider
10. You may also configure color quality and other standard display properties

3.3.2 Dual Display

The mediaBOX Media Player allows you to use any 2 of the 3 available video ports (i.e.: VGA and DVI, DVI and HDMI, HDMI and VGA, etc). Once you connect both displays, you should see both monitors appear under the Display settings.
To enable the secondary display, select the 2nd inactive monitor and click on the checkbox “Extend my Windows desktop onto this monitor”.

Note that you may also drag and drop each display box within the gray canvas to change the order and match your physical mounting installation.

You should know that in your Signage presentation a single screen division cannot surpass 2880 pixels in width or height. If the total width or height of both monitors exceeds 2880 pixels, you will need to break your screen setup into at least two divisions to compensate for this limitation. In most cases this is not a problem as multiple screen divisions are used. The SignagePlayer supports unlimited number of screen divisions.

### 3.3.3 Rotating the Display

The mediaBOX Media Player allows you to set each display in a landscape or portrait mode. To configure the rotation of the display you will use the Nvidia nView setup software.

To configure rotation of your display:

1. Press **Control > Alt > Delete**
2. Select **File > run** and type **control**
3. Under the control panel double click on **Display**
4. Select the settings tab
5. Select the monitor you wish to configure using the Display drop down
6. Click on **advanced**
7. Select the **Nvidia configuration** tab
8. Select **Start Nvidia Control Panel**
9. Select the **Display** icon
10. Select **Rotate Display**
11. Select the angle in degrees to rotate the display to
12. Select apply

3.4 Running the SignagePlayer

Running the SignagePlayer should always be done via SignageController.exe. It is the SignageController that executes the SignagePlayer. The SignageController is set automatically start upon bootup. The following registry key was modified in order to set the SignageController.exe to auto start:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RUN

To review this you can execute:

1. Press Control > Alt > Delete
2. Select File > Run
3. Enter regedit.exe

Note: The Registry is the main config database of the Windows XPe OS. Editing the registry is a high risk task. Modification of keys may cause the Windows registry to corrupt. Take special care when adding, modifying or deleting any entries in the registry.

3.5 Unregistering & clearing cache
4.0 Using the System (Online)

You can unregister your account directly on the SignagePlayer. Simply click on the “Unregister” button, provide your login email address and valid password and click ok. This will remove the local key and unregister your account with the SignagePlayer. It will also unregister the Player with the remote server and remove the Player from the list of available “Stations”.

You may also delete the SignagePlayer local cache directory for one of the following reasons:

1. You forgot your login email or password
2. You want to remove all cached content from Player including media files and RSS data
3. SignagePlayer is not working properly & you want to troubleshoot the issue by clearing everything

The SignagePlayer stores all account information and local cached content under:

C:\Documents and Settings\Administrator\Application Data\SignagePlayer*

To delete this directory follow the steps:

1. Close the SignagePlayer
2. Close the SignageController
3. Press Control > Alt > Delete
4. Select File > run and type Explorer
5. Change directory to C:\Documents and Settings\Administrator\Application Data
6. Delete the SignagePlayer* directory (* to be replaced with a very long number)
7. Reboot the Media Player
8. Re-register the SignagePlayer upon bootup

3.6 Maintenance

The mediaBOX Windows XPe edition does not require any special maintenance. The scandisk and other normal disk utilities were removed as the OS is designed to work as a peripheral.

It is however common practice to reboot or PC at least once a day. Although the SignagePlayer will run continuously without interruption for weeks or even months at a time, it is common practice to reboot once every 24 hours. Rebooting may help increase performance as system buffers will be refreshed and memory restored to zero fragmentation.
To configure a daily reboot, first register the SignagePlayer. Once registered open the SignageStudio, under “Stations” you will see your newly added BLACKBLOX player appear under the “Stations” data grid. Select it, and under its Properties > Reboot conditions set the checkbox. Set a time when you wish to set the automatic daily reboot. By default the SignagePlayer will reboot at 0:0 which is 12:00AM.

Note that there are other configurable reboot conditions as well which may cause the SignagePlayer to reboot, this includes memory threshold and internal error. These settings are applicable to both the Windows XPe OS as well as Ubuntu Linux OS.

The Automatic Adobe AIR auto updates were disabled in order to prevent popup messages which may come up during new Adobe AIR software releases. To enable the automatic updates temporarily so you can find out if a new Adobe AIR runtime is available you can run:

"C:\Program Files\Adobe AIR Settings Manager\Adobe AIR Settings Manager.exe"

and click "Enable Updates".
3.7 Remote Login

The Desktop SignagePlayer can be remotely controlled using the SignageStudio (Web or Desktop version). The remote functions include Play, Stop, update software builds, receive a live screen capture, poll memory stats and more. Under normal circumstances you should not need any further remote functionality. However, it is a good idea to plan for disaster recovery. Part of this plan is to allow for secure remote desktop access to the mediaBOX over the internet.

This type of access can be managed with the free service: LogMeIn® (visit http://www.LogMeIn.com). The LogMeIn® service will allow you to bypass firewalls and other restrictions to gain remote access to the mediaBOX. With LogMeIn® installed and pre-configured on your mediaBOX you will always have remote access to your Digital Signage player; just in case.

Read the end user license agreement at LogMeIn® for further details on the service and commercial / none commercial offering.

A second option of gaining remote secure access to your mediaBOX is to use the free application Tight VNC (visit http://www.tightvnc.com/). Note that with TightVNC you will need to use a static IP or use a port forwarding rule on your local internet gateway / router.

Again, both LogMeIn® and TightVNC are optional as the SignageStudio provides all of the essential remote management functions needed to operate and control the Desktop SignagePlayer.

3.8 White label setup

The Windows XPe is configured to display a custom boot up image. The image may be replaced with your own custom image. To modify the boot up image you must first create a windows bitmap (bmp) image file. The image must be 640x480 and set to 16 colors. Save the image under C:\Windows\boot.bmp.

The c:\boot.ini file specifies a boot logo flag which instructs the operating system to pre load the custom image during bootup.

The following is a sample c:\boot.ini file

[boot loader]
timeout=0
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows Embedded Standard"
/fastdetect /noguiboot /bootlogo /noexecute=AlwaysOff
4.0  Ubuntu Linux setup and configuration
4.1 User Interface

The Ubuntu Linux operating system was specifically compiled to serve as an appliance type device. The OS was loaded with an ultra light X11 Window Manager called Black Box (not to be confused with the Media Player mediaBOX). The Black Box Window Manager shell was stripped from all panels and desktop area to deliver the most efficient and reliable platform.

However you can still get the full power of the gnome Window Manager that is available for you to setup and management. To learn more about gnome you may visit:

http://www.gnome.org

To access the gnome panel right click on the black background and select Task Manager. Right clicking on the black background will pull additional menu options including reboot, open terminal, config utility to customize the Black Box environment and more.

You should explore the gnome panel to familiarize yourself with the available applications and utilities. Some of these applications include computer management, task manager and others. In the following sections we will cover the core configuration utilities that help with setting up the network and display properties.

4.2 Network setup

4.2.1 Wired Network

The mediaBOX ships with DHCP enabled by default. You can check network status by opening the gnome panel, right click black background and select Task Manager from the mouse right click properties menu. This will run the gnome management top panel.

Once the Task Manager loads you will see a computer icon on the top gnome panel:

If the icon is displayed with a red x, it means your network connection is OFF and you will need to configure your network settings manually.

To configure your TCP/IP wired network connection:

1. Right click on the black background and select Task Manager
2. From the gnome Task Manager select System > Preferences > Network Connections
3. Select the wired tab
4. Select network interface (Auth eth4)
5. Edit **preferences** to set your own static IP information
6. Select the **IP4** settings
7. Select the type of connection you want and set the IP setting
8. Click apply to save changes

---

### 4.2.2 Wireless Network

The mediaBOX is preconfigured with a wireless module. The following section covers the wireless configuration necessary to enable wireless connectivity to your local secure wireless network.

1. **Right click** on the **black background** and select **Task Manager**
2. On the Task Manager you will see a small computer icon
3. Click on the **computer icon** to view all available wireless networks
4. Once selected, you will be prompted to enter a wireless network key
5. Next you will need to provide the **root password**
   The root password is: `password`

   ![Unlock Keyring](image)

   **Enter password for default keyring to unlock**

   The application 'NetworkManager Applet' (/usr/bin/nm-applet) wants access to the default keyring, but it is locked

   Password: [Blank]

   ![Deny OK buttons](image)

6. Once all fields are authenticated the wireless status bar and signal strength will appear on the gnome panel

   ![Wireless Status Bar](image)

7. Next you will need to save and store the wireless password locally. This will eliminate the need to provide a password every time the mediaBOX boots up.

8. On the gnome panel click on **System > Preferences > Network Connections**. This will open the Network connections Dialogue. Select the 2\textsuperscript{nd} tab: **Wireless**.

   ![Network Connections](image)

9. Click on your **wireless network** (Auto Signage in our example ) and click on **Edit**

10. Next you will be prompted if you allow the application to access the wireless key
Select “Always allow”

11. Next you will be prompted for the root password again. Provide it.
12. On the Wireless network dialogue, select the lower checkbox for “Available to all users”

and click Apply

13. Now we will need to open the “Passwords and Encryption keys Application”.
   Again on the gnome panel select Applications > Accessories > Passwords and Encryption keys
14. Next select the Edit > Preferences and on the “Key Servers” tab select the “Publish keys to:” drop down and select the 1st entry of “hkp://keyserver.ubuntu.com:11371” Also select both checkboxes for automatic operations.
15. At this point you should be able to reboot and always connect to your local wireless secure network.

4.3 Display Configuration

The mediaBOX Media Player comes with 3 types of display connections including VGA, DVI and HDMI. You may use any one of these ports for your main display.

The mediaBOX Media Player also supports up to two active monitors per single box. When using two monitors you will have a desktop space which is the total of both monitor resolutions combined. In other words, you may create a signage presentation that spans both monitors. You can also configure the monitors in landscape or portrait mode.

4.3.1 Single display

To configure the mediaBOX screen display, Right click on the black background and select “Display Settings”. This will open up the Nvidia display configuration utility. You will use this utility to configure all aspects of your monitor configuration including resolution, rotation and monitor relative position.
Select the X Server Display configuration to enter the main settings section:
The display configuration screen allows you to control resolution, color depth as well as advanced settings.

### 4.3.2 Dual display

Note that you may also drag and drop each display box within the gray canvas to change the order and match your physical mounting installation.

You should know that in your Signage presentation a single screen division cannot surpass 2880 pixels in width or height. If the total width or height of both monitors combined exceeds 2880 pixels, you will need to break your screen setup into at least two divisions to compensate for this limitation. In most cases this is not a problem as multiple screen divisions are used. The SignagePlayer supports unlimited number of screen divisions.
4.3.3 Rotating the display

The Nvidia device driver allows you to rotate your display in portrait or landscape mode. To set this up, select the “Rotation Settings” from the main config tree. Click on the right or left arrow to rotate your display angle of view.

4.4 Running the SignagePlayer

The mediaBOX Media Player is configured to preload the SignagePlayer and SignageController upon bootup. It is configured to run the Black Box Windows Manager.

The following is the main Black Box startup configuration file located under: /home/user/.bbstartup
#!/bin/sh
bbkeys &
sudo chmod 777 -R /opt/SignagePlayer/share/linux
sudo xterm -geometry 60x40+10+10 /opt/SignagePlayer/share/linux/signageController.sh &
sleep 3
/usr/bin/blackbox

The Black Box startup config file (.bbstartup) will launch the signageController.sh which is the proper (and only) way of executing the Digital Signage and Kiosk presentation. The signageController.sh script is responsible for launching the SignageController and the SignagePlayer. It also maintains the health status of the SignageController and validates the integrity of all running processes.

The SignagePlayer installation resides in /opt/SignagePlayer
The SignagePlayer Linux configuration resides in /opt/SignagePlayer/share/linux
Cached content resides in /opt/SignagePlayer/share/buisnessXXX where XXX is your business account number.

The Linux environment comes with several command line aliases. These aliases are quick shortcuts which can be execute from any open terminal.

- **sign_run** = runs the Signage shell startup script
- **sign_cd** = change to SignagePlayer Linux directory
- **sign_unregister** = unregister the account and clear all cached cookie info
- **sign_clear** = remove all cached content
- **sign_showActive** = print all active signage relayed processes
- **sign_time** = configure timezone
- **sign_vnc** = enable remote management using vnc server

### 4.5 HDMI Sound

The Ubuntu mediaBOX is pre configured with standard audio through the back green mini jack output port. In order to enable HDMI sound through the HDMI port you should follow these steps:

1. Right click on the desktop and run **Terminal**
2. Run the command **sign_hdmi**
3. Reboot the mediaBOX

Once rebooted all sound controls should work through the HDMI port. The reverse procedure will reset the audio back to the standard mini jack port.

Advanced HDMI sound control can be managed through the: sudo alsamixer command (for advanced users only).
4.6 Maintenance

The mediaBOX Windows Ubuntu edition does not require any special maintenance. The fstab auto validation and other normal disk utilities were removed as the OS is designed to work as a peripheral.

It is however common practice to reboot or PC at least once a day. Although the SignagePlayer will run continuously without interruption for weeks or even months at a time, it is common practice to reboot once every 24 hours. Rebooting may help increase performance as system buffers flush and memory restored to zero fragmentation.

To configure a daily reboot, first register the SignagePlayer. Once registered open the SignageStudio, under “Stations” you will see your newly added BLACKBLOX player appear under the “Stations” data grid. Select it and under its Properties > Reboot conditions set the checkbox. Set a time when you wish to set the automatic daily reboot. By default the SignagePlayer will reboot at 0:0 which is 12:00AM.

Note that there are other configurable reboot conditions as well which may cause the SignagePlayer to reboot, this includes memory threshold and internal error. These settings are applicable to both the Windows XPe OS as well as Ubuntu Linux OS.

The Automatic Adobe AIR auto updates were disabled in order to prevent popup messages which may come up during new Adobe AIR software releases. To enable the automatic updates temporarily so you can find out if a new Adobe AIR runtime is available you can run:

```
/opt/ Adobe AIR Settings Manager/bin/Adobe AIR Settings Manager
```

and click “Enable Updates”.

User’s Manual
The Ubuntu automatic software updates were also disabled in order to prevent unnecessary downtime of the Media Player. If you would like to enable the automatic updates to check if new software is available:

1. **Right click** on the **black background** and select **Task Manager**
2. On the gnome panel select **System > Administration > Software Sources**
3. Change to the **Updates tab**
4. Select all check boxes and select the check for updates: Daily
4.7 Remote Login

The Desktop SignagePlayer can be remotely controlled using the SignageStudio (Web or Desktop version). The remote functions include Play, Stop, update software builds, receive a live screen capture, poll memory stats and more. Under normal circumstances you should not need any further remote functionality. However, it is a good idea to plan for disaster recovery. Part of this plan is to allow for secure remote desktop access to the mediaBOX over the internet.

The Ubuntu mediaBOX ships preconfigured with remote access. To enable remote access:

1. Right click on the Desktop and run Terminal
2. Type and run vino-preferences
3. Be sure to check the “Allow other users to view my desktop” as well as “Allow other users to Control my Desktop”. And it is also recommended that you set a “Required the user to enter password” field.
4. Close the vino-preferences
5. Type and run sign_vnc
6. Reboot

At this point you should be able to install TightVNC viewer on your personal Windows computer. To download the TightVNC viewer visit: [http://tightvnc.com/](http://tightvnc.com/)

From the TightVNC viewer you will enter the IP address of the mediaBOX to remote login to it. If you are unsure of the IP address of the mediaBOX, right click on the Desktop and run Terminal and enter ifconfig –a to view the IP address of the Eth1 interface.

Note that if the mediaBOX resides behind a firewall or within a private Local Area Network and it is not configured with a static IP, you will need to configure the local router / gateway with port forwarding. Port forwarding allows remote computers (e.g., public machines on the Internet) to connect to a specific computer within a private LAN. You should consult with your network administrator on how to enable port forwarding and map your mediaBOX for remote access.

4.8 White label setup

The mediaBOX Ubuntu Linux is powered by Splashy. Splashy is a custom boot loader utility which allows you modify the boot up image.

First begin by creating your own custom boot up image. The image must be in a in a png format. Name your custom image background.png and place it in:

/etc/splashy/themes/default

Once the image has been copied you will need to update the system with the following commands:

update-initramfs –u
**sudo update-grub**

This will apply your new custom bootup image as part of the internal system.

Reboot the mediaBOX Media Player and you should be able to preview your image as part of the boot up and shutdown process.
5.0 MONITORING AND ADMINISTRATION
5.1 Watchdog

The SignageController (also known as Watchdog) is a vital part of the Media Player software suit. It insures that the SignagePlayer is running at all times and monitors the health status of the player. It is also responsible for rebooting the SignagePlayer, provides remote snapshots and more. You should confirm that the SignageController is running. You can tell if the SignageController is running using two methods:

Method 1: Using the SignageStudio switch to “Stations” and view the data grid. Each connected SignagePlayer is marked with a colored LED. If the LED icon is marked in yellow, it means that the SignagePlayer is connected to the backend server; however the SignageController is not running. A Red LED means the SignagePlayer is not connecting and a Green LED means that all systems are good; SignageController is running and the SignagePlayer is connected.

<table>
<thead>
<tr>
<th>Connection</th>
<th>Station</th>
<th>Last Update</th>
<th>Last Status</th>
<th>Caching</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>MyStation</td>
<td>2:17:06:00</td>
<td>Closed</td>
<td>19 of 19</td>
</tr>
<tr>
<td></td>
<td>Ubuntu</td>
<td>2:23:07:35</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Method 2: Simply by looking at the graphical user interface of the SignagePlayer you can tell the status of both SignageController and status connection to the backend server.

5.2 Real time snapshots

The SignagePlayer allows you to get live real time snapshot. These snapshots are a great tool to see what is running at a specific location. To get a live snapshot the SignageController must be running. In the SignageStudio go to “Stations” and click on the camera icon to get a live preview of the remote SignagePlayer Desktop.